What’s Vulnerable › Vulnerabilities
CVE-2017-20283
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-15
- Weakness: CWE-787
Description
NXP MQX Classic before 5.0 contains an out-of-bounds write vulnerability in the RTCS UDP recvfrom() implementation. Improper enforcement of the application-supplied receive buffer length may allow a crafted UDP packet to overflow the destination buffer, resulting in memory corruption, or denial of service.
Affected products
- NXP MQX: before 5.0 Classic — fixed in 5.0 Classic
How to fix
Upgrade to a fixed version: NXP MQX 5.0 Classic. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-20283 or the next vulnerability affects your stack