What’s Vulnerable › Vulnerabilities
CVE-2017-20287: Javo Spot WordPress Theme < 3.0.0 Path Traversal via admin-ajax.php fn Parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-28
- Weakness: CWE-22
Description
Javo Spot theme for WordPress before 3.0.0 contains a path traversal vulnerability that allows unauthenticated attackers to read arbitrary files via the fn parameter of the jvfrm_spot_get_json AJAX action. Attackers can send GET requests to /wp-admin/admin-ajax.php with fn set to ../../wp-config.php to retrieve database credentials and secret keys. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Javo Themes Javo Spot: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Javo Themes Javo Spot 3.0.0. Check the vendor advisory for mitigations.
References
- https://codeseekah.com/2017/02/09/javo-themes-spot-lfi-vulnerability/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-javospot-lfi.yaml
- https://themeforest.net/item/javo-spot-multi-purpose-directory-wordpress-theme/13198068
- https://wpscan.com/vulnerability/2d465fc4-d4fa-43bb-9c0d-71dcc3ee4eab
- https://www.vulncheck.com/advisories/javo-spot-wordpress-theme-3.0.0-path-traversal-via-admin-ajax-php-fn-parameter
- https://wpscan.com/vulnerability/2d465fc4-d4fa-43bb-9c0d-71dcc3ee4eab/
Get alerted when CVE-2017-20287 or the next vulnerability affects your stack