What’s Vulnerable › Vulnerabilities
CVE-2017-20289: Broadstreet Ad Widget WordPress Plugin < 2.12.0 Local File Inclusion via step parameter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-23
- Weakness: CWE-98
Description
Broadstreet Ad Widget plugin for WordPress 2.2.0 before 2.12.0 contains a local file inclusion vulnerability that allows authenticated users to execute attacker-chosen PHP files by passing unsanitized input to require in views/modal/index.php. Attackers can supply directory traversal sequences in the 'step' parameter, optionally with a null byte, to include local files and execute PHP code. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Broadstreet Ad Widget: from 2.2.0 before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: Broadstreet Ad Widget 2.12.0. Check the vendor advisory for mitigations.
References
- https://cxsecurity.com/issue/WLB-2017100084
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/ad-widget-lfi.yaml
- https://packetstorm.news/files/id/144553/
- https://plugins.trac.wordpress.org/changeset/1628751/ad-widget
- https://wordpress.org/plugins/ad-widget/
- https://wpscan.com/vulnerability/caca21fe-56bf-4d4c-afc8-4a218e52f0a2
- https://www.vulncheck.com/advisories/broadstreet-ad-widget-wordpress-plugin-2.12.0-local-file-inclusion-via-step-parameter
Get alerted when CVE-2017-20289 or the next vulnerability affects your stack