What’s Vulnerable › Vulnerabilities
CVE-2017-2297
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-01 · updated 2026-06-17
- Weakness: CWE-287
Description
Puppet Enterprise versions prior to 2016.4.5 and 2017.2.1 did not correctly authenticate users before returning labeled RBAC access tokens. This issue has been fixed in Puppet Enterprise 2016.4.5 and 2017.2.1. This only affects users with labeled tokens, which is not the default for tokens.
Affected products
- Puppet Enterprise: before 2016.4.5; 2016.5.1, 2016.5.2, 2017.1.0, 2017.1.1 — fixed in 2016.4.5
How to fix
Upgrade to a fixed version: Puppet Enterprise 2016.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-2297 or the next vulnerability affects your stack