What’s Vulnerable › Vulnerabilities
CVE-2017-2355
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-02-20 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in certain Apple products. iOS before 10.2.1 is affected. Safari before 10.0.3 is affected. iCloud before 6.1.1 is affected. iTunes before 12.5.5 is affected. tvOS before 10.1.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (uninitialized memory access and application crash) via a crafted web site.
Affected products
- Apple iCloud for Windows: before 6.1.1 — fixed in 6.1.1
- Apple Iphone Os: before 10.2.1 — fixed in 10.2.1
- Apple iTunes for Windows: before 12.5.5 — fixed in 12.5.5
- Apple Safari: before 10.0.3 — fixed in 10.0.3
- Apple tvOS: before 10.1.1 — fixed in 10.1.1
- Webkitgtk+: before 2.16.3 — fixed in 2.16.3
How to fix
Upgrade to a fixed version: Apple iCloud for Windows 6.1.1; Apple Iphone Os 10.2.1; Apple iTunes for Windows 12.5.5; Apple Safari 10.0.3; Apple tvOS 10.1.1; Webkitgtk+ 2.16.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95736
- http://www.securitytracker.com/id/1037668
- https://security.gentoo.org/glsa/201706-15
- https://support.apple.com/HT207481
- https://support.apple.com/HT207482
- https://support.apple.com/HT207484
- https://support.apple.com/HT207485
- https://support.apple.com/HT207486
- http://www.securityfocus.com/bid/95736
- http://www.securitytracker.com/id/1037668
- https://security.gentoo.org/glsa/201706-15
- https://support.apple.com/HT207481
Get alerted when CVE-2017-2355 or the next vulnerability affects your stack