What’s Vulnerable › Vulnerabilities
CVE-2017-2581
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-787
Description
An out-of-bounds write vulnerability was found in netpbm before 10.61. A maliciously crafted file could cause the application to crash or possibly allow code execution.
Affected products
- netpbm: before 10.61.00 — fixed in 10.61.00
How to fix
Upgrade to a fixed version: netpbm 10.61.00. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96710
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2581
- http://www.securityfocus.com/bid/96710
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2581
Get alerted when CVE-2017-2581 or the next vulnerability affects your stack