What’s Vulnerable › Vulnerabilities
CVE-2017-2590
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-732
Description
A vulnerability was found in ipa before 4.4. IdM's ca-del, ca-disable, and ca-enable commands did not properly check the user's permissions while modifying CAs in Dogtag. An authenticated, unauthorized attacker could use this flaw to delete, disable, or enable CAs causing various denial of service problems with certificate issuance, OCSP signing, and deletion of secret keys.
Affected products
- FreeIPA ipa: before 4.4.0 — fixed in 4.4.0
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: FreeIPA ipa 4.4.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0388.html
- http://www.securityfocus.com/bid/96557
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2590
- http://rhn.redhat.com/errata/RHSA-2017-0388.html
- http://www.securityfocus.com/bid/96557
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2590
Get alerted when CVE-2017-2590 or the next vulnerability affects your stack