What’s Vulnerable › Vulnerabilities
CVE-2017-2598
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-325
Description
Jenkins before versions 2.44, 2.32.2 uses AES ECB block cipher mode without IV for encrypting secrets which makes Jenkins and the stored secrets vulnerable to unnecessary risks (SECURITY-304).
Affected products
- Jenkins: before 2.44; before 2.32.2 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95948
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2598
- https://github.com/jenkinsci/jenkins/commit/e6aa166246d1734f4798a9e31f78842f4c85c28b
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95948
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2598
- https://github.com/jenkinsci/jenkins/commit/e6aa166246d1734f4798a9e31f78842f4c85c28b
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2598 or the next vulnerability affects your stack