What’s Vulnerable › Vulnerabilities
CVE-2017-2599
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-11 · updated 2026-06-17
- Weakness: CWE-863
Description
Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. This allows users with permissions to create new items (e.g. jobs) to overwrite existing items they don't have access to (SECURITY-321).
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95949
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2599
- https://github.com/jenkinsci/jenkins/commit/4ed5c850b6855ab064a66d02fb338f366853ce89
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95949
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2599
- https://github.com/jenkinsci/jenkins/commit/4ed5c850b6855ab064a66d02fb338f366853ce89
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2599 or the next vulnerability affects your stack