What’s Vulnerable › Vulnerabilities
CVE-2017-2602
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-184
Description
jenkins before versions 2.44, 2.32.2 is vulnerable to an improper blacklisting of the Pipeline metadata files in the agent-to-master security subsystem. This could allow metadata files to be written to by malicious agents (SECURITY-358).
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95952
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2602
- https://github.com/jenkinsci/jenkins/commit/414ff7e30aba66bed18c4ee8a8660fb36fc8c655
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95952
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2602
- https://github.com/jenkinsci/jenkins/commit/414ff7e30aba66bed18c4ee8a8660fb36fc8c655
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2602 or the next vulnerability affects your stack