What’s Vulnerable › Vulnerabilities
CVE-2017-2603
- Severity: low (CVSS 3.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-325
Description
Jenkins before versions 2.44, 2.32.2 is vulnerable to a user data leak in disconnected agents' config.xml API. This could leak sensitive data such as API tokens (SECURITY-362).
Affected products
- Jenkins: before 2.44; before 2.32.2 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95955
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2603
- https://github.com/jenkinsci/jenkins/commit/3cd946cbef82c6da5ccccf3890d0ae4e091c4265
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95955
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2603
- https://github.com/jenkinsci/jenkins/commit/3cd946cbef82c6da5ccccf3890d0ae4e091c4265
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2603 or the next vulnerability affects your stack