What’s Vulnerable › Vulnerabilities
CVE-2017-2604
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-358
Description
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently protected by permission checks (SECURITY-371).
Affected products
- Jenkins: before 2.44; before 2.32.2 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95959
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2604
- https://github.com/jenkinsci/jenkins/commit/6efcf6c2ac39bc5c59ac7251822be8ddf67ceaf8
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95959
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2604
- https://github.com/jenkinsci/jenkins/commit/6efcf6c2ac39bc5c59ac7251822be8ddf67ceaf8
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2604 or the next vulnerability affects your stack