What’s Vulnerable › Vulnerabilities
CVE-2017-2606
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-08 · updated 2026-06-17
- Weakness: CWE-200
Description
Jenkins before versions 2.44, 2.32.2 is vulnerable to an information exposure in the internal API that allows access to item names that should not be visible (SECURITY-380). This only affects anonymous users (other users legitimately have access) that were able to get a list of items via an UnprotectedRootAction.
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95962
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2606
- https://github.com/jenkinsci/jenkins/commit/09cfbc9cd5c9df7c763bc976b7f5c51266b63719
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95962
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2606
- https://github.com/jenkinsci/jenkins/commit/09cfbc9cd5c9df7c763bc976b7f5c51266b63719
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2606 or the next vulnerability affects your stack