What’s Vulnerable › Vulnerabilities
CVE-2017-2607
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-21 · updated 2026-06-17
- Weakness: CWE-79
Description
jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting vulnerability in console notes (SECURITY-382). Jenkins allows plugins to annotate build logs, adding new content or changing the presentation of existing content while the build is running. Malicious Jenkins users, or users with SCM access, could configure jobs or modify build scripts such that they print serialized console notes that perform cross-site scripting attacks on Jenkins users viewing the build logs.
Affected products
- Jenkins: before 2.44; before 2.32.2 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95963
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2607
- http://www.securityfocus.com/bid/95963
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2607
Get alerted when CVE-2017-2607 or the next vulnerability affects your stack