What’s Vulnerable › Vulnerabilities
CVE-2017-2608
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-502
Description
Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).
Affected products
- Jenkins: through 2.44; before 2.32.2 — fixed in 2.32.2
How to fix
Upgrade to a fixed version: Jenkins 2.32.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95953
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2608
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95953
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2608
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2608 or the next vulnerability affects your stack