What’s Vulnerable › Vulnerabilities
CVE-2017-2609
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-22 · updated 2026-06-17
- Weakness: CWE-200
Description
jenkins before versions 2.44, 2.32.2 is vulnerable to an information disclosure vulnerability in search suggestions (SECURITY-385). The autocomplete feature on the search box discloses the names of the views in its suggestions, including the ones for which the current user does not have access to.
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95964
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2609
- https://github.com/jenkinsci/jenkins/commit/13905d8224899ba7332fe9af4e330ea96a2ae319
- http://www.securityfocus.com/bid/95964
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2609
- https://github.com/jenkinsci/jenkins/commit/13905d8224899ba7332fe9af4e330ea96a2ae319
Get alerted when CVE-2017-2609 or the next vulnerability affects your stack