What’s Vulnerable › Vulnerabilities
CVE-2017-2610
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting in search suggestions due to improperly escaping users with less-than and greater-than characters in their names (SECURITY-388).
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95951
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2610
- https://github.com/jenkinsci/jenkins/commit/307ed31caba68a46426b8c73a787a05add2c7489
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95951
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2610
- https://github.com/jenkinsci/jenkins/commit/307ed31caba68a46426b8c73a787a05add2c7489
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2610 or the next vulnerability affects your stack