What’s Vulnerable › Vulnerabilities
CVE-2017-2612
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-358
Description
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to override JDK download credentials (SECURITY-392), resulting in future builds possibly failing to download a JDK.
Affected products
- Jenkins: before 2.44; before 2.32.2 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95957
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2612
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95957
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2612
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2612 or the next vulnerability affects your stack