What’s Vulnerable › Vulnerabilities
CVE-2017-2613
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-15 · updated 2026-06-17
- Weakness: CWE-770
Description
jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins. While this user record was only retained until restart in most cases, administrators' web browsers could be manipulated to create a large number of user records (SECURITY-406).
Affected products
- Jenkins: before 2.32.2; before 2.44 — fixed in 2.32.2, 2.44
How to fix
Upgrade to a fixed version: Jenkins 2.32.2, 2.44. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/95967
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2613
- https://github.com/jenkinsci/jenkins/commit/b88b20ec473200db35d0a0d29dcf192069106601
- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95967
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2613
- https://github.com/jenkinsci/jenkins/commit/b88b20ec473200db35d0a0d29dcf192069106601
- https://jenkins.io/security/advisory/2017-02-01/
Get alerted when CVE-2017-2613 or the next vulnerability affects your stack