What’s Vulnerable › Vulnerabilities
CVE-2017-2617
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-22 · updated 2026-06-17
- Weakness: CWE-20
Description
hawtio before version 1.5.5 is vulnerable to remote code execution via file upload. An attacker could use this vulnerability to upload a crafted file which could be executed on a target machine where hawtio is deployed.
Affected products
- [UNKNOWN] hawtio: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: [UNKNOWN] hawtio 1.5.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96036
- https://access.redhat.com/errata/RHSA-2018:0319
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2617
- http://www.securityfocus.com/bid/96036
- https://access.redhat.com/errata/RHSA-2018:0319
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2617
Get alerted when CVE-2017-2617 or the next vulnerability affects your stack