What’s Vulnerable › Vulnerabilities
CVE-2017-2620
- Severity: critical (CVSS 9.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-787
Description
Quick emulator (QEMU) before 2.8 built with the Cirrus CLGD 54xx VGA Emulator support is vulnerable to an out-of-bounds access issue. The issue could occur while copying VGA data in cirrus_bitblt_cputovideo. A privileged user inside guest could use this flaw to crash the QEMU process OR potentially execute arbitrary code on host with privileges of the QEMU process.
Affected products
- Citrix XenServer: 6.2.0-sp1, 6.5-sp1; 6.0.2, 7.0, 7.1 (and their updates)
- Debian Linux: 7.0 (and their updates)
- QEMU: before 2.8.0 — fixed in 2.8.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0 (and their updates)
- RedHat Enterprise Linux Server: 6.0, 7.0 (and their updates)
- RedHat Enterprise Linux Server Aus: 7.3, 7.4 (and their updates)
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5 (and their updates)
- RedHat Enterprise Linux Workstation: 6.0, 7.0 (and their updates)
- OpenStack: 5.0, 6.0, 7.0, 8, 9, 10 (and their updates)
- xen: through 4.7.1; 4.7.1-r1, 4.7.1-r2, 4.7.1-r3, 4.7.1-r4, 4.7.1-r5, 4.7.1-r6 (+1)
- QEMU: 2.8
How to fix
Upgrade to a fixed version: QEMU 2.8.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0328.html
- http://rhn.redhat.com/errata/RHSA-2017-0329.html
- http://rhn.redhat.com/errata/RHSA-2017-0330.html
- http://rhn.redhat.com/errata/RHSA-2017-0331.html
- http://rhn.redhat.com/errata/RHSA-2017-0332.html
- http://rhn.redhat.com/errata/RHSA-2017-0333.html
- http://rhn.redhat.com/errata/RHSA-2017-0334.html
- http://rhn.redhat.com/errata/RHSA-2017-0350.html
- http://rhn.redhat.com/errata/RHSA-2017-0351.html
- http://rhn.redhat.com/errata/RHSA-2017-0352.html
- http://rhn.redhat.com/errata/RHSA-2017-0396.html
- http://rhn.redhat.com/errata/RHSA-2017-0454.html
Get alerted when CVE-2017-2620 or the next vulnerability affects your stack