What’s Vulnerable › Vulnerabilities
CVE-2017-2630
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack buffer overflow flaw was found in the Quick Emulator (QEMU) before 2.9 built with the Network Block Device (NBD) client support. The flaw could occur while processing server's response to a 'NBD_OPT_LIST' request. A malicious NBD server could use this issue to crash a remote NBD client resulting in DoS or potentially execute arbitrary code on client host with privileges of the QEMU process.
Affected products
- QEMU: before 2.9 — fixed in 2.9
How to fix
Upgrade to a fixed version: QEMU 2.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/02/15/2
- http://www.securityfocus.com/bid/96265
- https://access.redhat.com/errata/RHSA-2017:2392
- https://bugzilla.redhat.com/show_bug.cgi?id=1422415
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2630
- https://github.com/qemu/qemu/commit/2563c9c6b8670400c48e562034b321a7cf3d9a85
- https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg01246.html
- https://security.gentoo.org/glsa/201704-01
- http://www.openwall.com/lists/oss-security/2017/02/15/2
- http://www.securityfocus.com/bid/96265
- https://access.redhat.com/errata/RHSA-2017:2392
- https://bugzilla.redhat.com/show_bug.cgi?id=1422415
Get alerted when CVE-2017-2630 or the next vulnerability affects your stack