What’s Vulnerable › Vulnerabilities
CVE-2017-2632
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-285
Description
A logic error in valid_role() in CloudForms role validation before 5.7.1.3 could allow a tenant administrator to create groups with a higher privilege level than the tenant administrator should have. This would allow an attacker with tenant administration access to elevate privileges.
Affected products
- CloudForms: 4.2
- Red Hat CloudForms: before 5.7.1.3 — fixed in 5.7.1.3
How to fix
Upgrade to a fixed version: Red Hat CloudForms 5.7.1.3. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0320.html
- http://www.securityfocus.com/bid/96478
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2632
- http://rhn.redhat.com/errata/RHSA-2017-0320.html
- http://www.securityfocus.com/bid/96478
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2632
Get alerted when CVE-2017-2632 or the next vulnerability affects your stack