What’s Vulnerable › Vulnerabilities
CVE-2017-2636
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-07 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in drivers/tty/n_hdlc.c in the Linux kernel through 4.10.1 allows local users to gain privileges or cause a denial of service (double free) by setting the HDLC line discipline.
Affected products
- Debian Linux: 8.0
- Linux kernel: from 2.6.31 before 3.2.87; from 3.3 before 3.10.106; from 3.11 before 3.12.72; from 3.13 before 3.16.42; from 3.17 before 3.18.49; from 3.19 before 4.1.49 — fixed in 3.10.106, 3.12.72, 3.16.42, 3.18.49, 3.2.87, 4.1.49
How to fix
Upgrade to a fixed version: Linux kernel 3.10.106, 3.12.72, 3.16.42, 3.18.49. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3804
- http://www.openwall.com/lists/oss-security/2017/03/07/6
- http://www.securityfocus.com/bid/96732
- http://www.securitytracker.com/id/1037963
- https://a13xp0p0v.github.io/2017/03/24/CVE-2017-2636.html
- https://access.redhat.com/errata/RHSA-2017:0892
- https://access.redhat.com/errata/RHSA-2017:0931
- https://access.redhat.com/errata/RHSA-2017:0932
- https://access.redhat.com/errata/RHSA-2017:0933
- https://access.redhat.com/errata/RHSA-2017:0986
- https://access.redhat.com/errata/RHSA-2017:1125
- https://access.redhat.com/errata/RHSA-2017:1126
Get alerted when CVE-2017-2636 or the next vulnerability affects your stack