What’s Vulnerable › Vulnerabilities
CVE-2017-2638
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-16 · updated 2026-06-17
- Weakness: CWE-306
Description
It was found that the REST API in Infinispan before version 9.0.0 did not properly enforce auth constraints. An attacker could use this vulnerability to read or modify data in the default cache or a known cache name.
Affected products
- Red Hat infinispan: before 9.0.0 — fixed in 9.0.0
- RedHat Jboss Data Grid: 7.1
How to fix
Upgrade to a fixed version: Red Hat infinispan 9.0.0. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-1097.html
- http://www.securityfocus.com/bid/97964
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2638
- https://github.com/infinispan/infinispan/pull/4936/commits
- https://issues.jboss.org/browse/ISPN-7485
- http://rhn.redhat.com/errata/RHSA-2017-1097.html
- http://www.securityfocus.com/bid/97964
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2638
- https://github.com/infinispan/infinispan/pull/4936/commits
- https://issues.jboss.org/browse/ISPN-7485
Get alerted when CVE-2017-2638 or the next vulnerability affects your stack