What’s Vulnerable › Vulnerabilities
CVE-2017-2640
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-787
Description
An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.
Affected products
- Debian Linux: 8.0
- Pidgin: before 2.12.0 — fixed in 2.12.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4
- RedHat Enterprise Linux Server Eus: 7.4, 7.5
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Pidgin 2.12.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96775
- https://access.redhat.com/errata/RHSA-2017:1854
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2640
- https://security.gentoo.org/glsa/201706-10
- https://www.debian.org/security/2017/dsa-3806
- http://www.securityfocus.com/bid/96775
- https://access.redhat.com/errata/RHSA-2017:1854
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2640
- https://security.gentoo.org/glsa/201706-10
- https://www.debian.org/security/2017/dsa-3806
Get alerted when CVE-2017-2640 or the next vulnerability affects your stack