What’s Vulnerable › Vulnerabilities
CVE-2017-2648
- Severity: medium (CVSS 5.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-295
Description
It was found that jenkins-ssh-slaves-plugin before version 1.15 did not perform host key verification, thereby enabling Man-in-the-Middle attacks.
Affected products
- jenkins-ssh-slaves-plugin: before 1.15 — fixed in 1.15
How to fix
Upgrade to a fixed version: jenkins-ssh-slaves-plugin 1.15. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96985
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2648
- https://jenkins.io/security/advisory/2017-03-20/
- http://www.securityfocus.com/bid/96985
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2648
- https://jenkins.io/security/advisory/2017-03-20/
Get alerted when CVE-2017-2648 or the next vulnerability affects your stack