What’s Vulnerable › Vulnerabilities
CVE-2017-2651
- Severity: low (CVSS 3.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-27 · updated 2026-06-17
- Weakness: CWE-200
Description
jenkins-mailer-plugin before version 1.20 is vulnerable to an information disclosure while using the feature to send emails to a dynamically created list of users based on the changelogs. This could in some cases result in emails being sent to people who have no user account in Jenkins, and in rare cases even people who were not involved in whatever project was being built, due to some mapping based on the local-part of email addresses.
Affected products
- Jenkins project Jenkins Mailer Plugin: before 1.20 — fixed in 1.20
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Mailer Plugin 1.20. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/96984
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2651
- https://jenkins.io/security/advisory/2017-03-20/
- http://www.securityfocus.com/bid/96984
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2651
- https://jenkins.io/security/advisory/2017-03-20/
Get alerted when CVE-2017-2651 or the next vulnerability affects your stack