What’s Vulnerable › Vulnerabilities
CVE-2017-2659
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-209
Description
It was found that dropbear before version 2013.59 with GSSAPI leaks whether given username is valid or invalid. When an invalid username is given, the GSSAPI authentication failure was incorrectly counted towards the maximum allowed number of password attempts.
Affected products
- [UNKNOWN] dropbear: before 2013.59 — fixed in 2013.59
How to fix
Upgrade to a fixed version: [UNKNOWN] dropbear 2013.59. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2659
- https://secure.ucc.asn.au/hg/dropbear/rev/d7784616409a#l1.86
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2659
- https://secure.ucc.asn.au/hg/dropbear/rev/d7784616409a#l1.86
Get alerted when CVE-2017-2659 or the next vulnerability affects your stack