What’s Vulnerable › Vulnerabilities
CVE-2017-2661
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
ClusterLabs pcs before version 0.9.157 is vulnerable to a cross-site scripting vulnerability due to improper validation of Node name field when creating new cluster or adding existing cluster.
Affected products
- ClusterLabs pcs: before 0.9.157 — fixed in 0.9.157
How to fix
Upgrade to a fixed version: ClusterLabs pcs 0.9.157. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1428948
- https://github.com/ClusterLabs/pcs/commit/1874a769b5720ae5430f10c6cedd234430bc703f
- https://bugzilla.redhat.com/show_bug.cgi?id=1428948
- https://github.com/ClusterLabs/pcs/commit/1874a769b5720ae5430f10c6cedd234430bc703f
Get alerted when CVE-2017-2661 or the next vulnerability affects your stack