What’s Vulnerable › Vulnerabilities
CVE-2017-2668
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-22 · updated 2026-06-17
- Weakness: CWE-119
Description
389-ds-base before versions 1.3.5.17 and 1.3.6.10 is vulnerable to an invalid pointer dereference in the way LDAP bind requests are handled. A remote unauthenticated attacker could use this flaw to make ns-slapd crash via a specially crafted LDAP bind request, resulting in denial of service.
Affected products
- Red Hat, Inc. 389-ds-base: from 1.3.5.0 before 1.3.5.17; from 1.3.6.0 before 1.3.6.10 — fixed in 1.3.5.17, 1.3.6.10
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Red Hat, Inc. 389-ds-base 1.3.5.17, 1.3.6.10. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/97524
- https://access.redhat.com/errata/RHSA-2017:0893
- https://access.redhat.com/errata/RHSA-2017:0920
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2668
- https://pagure.io/389-ds-base/issue/49220
- http://www.securityfocus.com/bid/97524
- https://access.redhat.com/errata/RHSA-2017:0893
- https://access.redhat.com/errata/RHSA-2017:0920
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2668
- https://pagure.io/389-ds-base/issue/49220
Get alerted when CVE-2017-2668 or the next vulnerability affects your stack