What’s Vulnerable › Vulnerabilities
CVE-2017-3167
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-06-20 · updated 2026-06-17
- Weakness: CWE-287
Description
In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.
Affected products
- Apache HTTP Server: from 2.2.0 before 2.2.33; from 2.4.0 before 2.4.26 — fixed in 2.2.33, 2.4.26
- macOS: before 10.13.1 — fixed in 10.13.1
- Debian Linux: 8.0, 9.0
- Clustered Data ONTAP: all versions
- NetApp OnCommand Unified Manager for 7-Mode (core package): all versions
- NetApp StorageGRID: all versions
- Oracle Corporation Secure Global Desktop: 5.3
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 6.7, 7.2, 7.3, 7.4, 7.5, 7.6 (+1)
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.2, 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- RedHat Jboss Core Services: 1.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.2.33, 2.4.26; macOS 10.13.1. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3896
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- http://www.securityfocus.com/bid/99135
- http://www.securitytracker.com/id/1038711
- https://access.redhat.com/errata/RHSA-2017:2478
- https://access.redhat.com/errata/RHSA-2017:2479
- https://access.redhat.com/errata/RHSA-2017:2483
- https://access.redhat.com/errata/RHSA-2017:3193
- https://access.redhat.com/errata/RHSA-2017:3194
- https://access.redhat.com/errata/RHSA-2017:3195
- https://access.redhat.com/errata/RHSA-2017:3475
- https://access.redhat.com/errata/RHSA-2017:3476
Get alerted when CVE-2017-3167 or the next vulnerability affects your stack