What’s Vulnerable › Vulnerabilities
CVE-2017-3210: Applications developed using the Portrait Display SDK, versions 2.30 through 2.34, default to insecure configurations which allow arbitrary code execution
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-24 · updated 2026-06-17
- Weakness: CWE-276
Description
Applications developed using the Portrait Display SDK, versions 2.30 through 2.34, default to insecure configurations which allow arbitrary code execution. A number of applications developed using the Portrait Displays SDK do not use secure permissions when running. These applications run the component pdiservice.exe with NT AUTHORITY/SYSTEM permissions. This component is also read/writable by all Authenticated Users. This allows local authenticated attackers to run arbitrary code with SYSTEM privileges. The following applications have been identified by Portrait Displays as affected: Fujitsu DisplayView Click: Version 6.0 and 6.01. The issue was fixed in Version 6.3. Fujitsu DisplayView Click Suite: Version 5. The issue is addressed by patch in Version 5.9. HP Display Assistant: Version 2.1. The issue was fixed in Version 2.11. HP My Display: Version 2.0. The issue was fixed in Version 2.1. Philips Smart Control Premium: Versions 2.23, 2.25. The issue was fixed in Version 2.26.
Affected products
- Fujitsu Displayview Click: 6.0, 6.01
- Fujitsu Displayview Click Suite: 5.0
- HP Display Assistant: 2.1
- HP My Display: 2.0
- Philips Smart Control Premium: 2.23, 2.25
- Portrait Display Sdk: from 2.30 before 2.34 — fixed in 2.34
How to fix
Upgrade to a fixed version: Portrait Display Sdk 2.34. Check the vendor advisory for mitigations.
References
- https://www.kb.cert.org/vuls/id/219739
- https://www.securityfocus.com/bid/98006
- https://www.kb.cert.org/vuls/id/219739
- https://www.securityfocus.com/bid/98006
Get alerted when CVE-2017-3210 or the next vulnerability affects your stack