What’s Vulnerable › Vulnerabilities
CVE-2017-3257
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-27 · updated 2026-06-17
- Weakness: CWE-269
Description
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: InnoDB). Supported versions that are affected are 5.6.34 and earlier5.7.16 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS v3.0 Base Score 6.5 (Availability impacts).
Affected products
- Debian Linux: 8.0
- MariaDB: from 10.0.0 before 10.0.29; from 10.1.0 before 10.1.21; from 10.2.0 before 10.2.8 — fixed in 10.0.29, 10.1.21, 10.2.8
- MySQL Server: from 5.6.0 through 5.6.34; from 5.7.0 through 5.7.16
How to fix
Upgrade to a fixed version: MariaDB 10.0.29, 10.1.21, 10.2.8. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3770
- http://www.oracle.com/technetwork/security-advisory/cpujan2017-2881727.html
- http://www.securityfocus.com/bid/95589
- http://www.securitytracker.com/id/1037640
- https://access.redhat.com/errata/RHSA-2017:2787
- https://access.redhat.com/errata/RHSA-2017:2886
- https://access.redhat.com/errata/RHSA-2018:0279
- https://access.redhat.com/errata/RHSA-2018:0574
- https://security.gentoo.org/glsa/201702-17
- https://security.gentoo.org/glsa/201702-18
- http://www.debian.org/security/2017/dsa-3770
- http://www.oracle.com/technetwork/security-advisory/cpujan2017-2881727.html
Get alerted when CVE-2017-3257 or the next vulnerability affects your stack