What’s Vulnerable › Vulnerabilities
CVE-2017-3265
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-27 · updated 2026-06-17
Description
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Packaging). Supported versions that are affected are 5.5.53 and earlier, 5.6.34 and earlier and 5.7.16 and earlier. Difficult to exploit vulnerability allows high privileged attacker with logon to the infrastructure where MySQL Server executes to compromise MySQL Server. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS v3.0 Base Score 5.6 (Confidentiality and Availability impacts).
Affected products
- Debian Linux: 8.0
- MariaDB: from 5.5.0 before 5.5.54; from 10.0.0 before 10.0.29; from 10.1.0 before 10.1.21 — fixed in 10.0.29, 10.1.21, 5.5.54
- MySQL Server: from 5.5.0 through 5.5.53; from 5.6.0 through 5.6.34; from 5.7.0 through 5.7.16
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Eus: 7.4, 7.5, 7.6, 7.7
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.6, 7.7
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: MariaDB 10.0.29, 10.1.21, 5.5.54. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3767
- http://www.debian.org/security/2017/dsa-3770
- http://www.oracle.com/technetwork/security-advisory/cpujan2017-2881727.html
- http://www.securityfocus.com/bid/95520
- http://www.securitytracker.com/id/1037640
- https://access.redhat.com/errata/RHSA-2017:2192
- https://access.redhat.com/errata/RHSA-2017:2787
- https://access.redhat.com/errata/RHSA-2018:0279
- https://access.redhat.com/errata/RHSA-2018:0574
- https://security.gentoo.org/glsa/201702-17
- https://security.gentoo.org/glsa/201702-18
- http://www.debian.org/security/2017/dsa-3767
Get alerted when CVE-2017-3265 or the next vulnerability affects your stack