What’s Vulnerable › Vulnerabilities
CVE-2017-3636
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-08 · updated 2026-06-17
Description
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Client programs). Supported versions that are affected are 5.5.56 and earlier and 5.6.36 and earlier. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where MySQL Server executes to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data as well as unauthorized read access to a subset of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.0 Base Score 5.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L).
Affected products
- Debian Linux: 8.0, 9.0
- MariaDB: from 5.5.0 before 5.5.57; from 10.0.0 before 10.0.32; from 10.1.0 before 10.1.26; from 10.2.0 before 10.2.8 — fixed in 10.0.32, 10.1.26, 10.2.8, 5.5.57
- MySQL Server: from 5.5.0 through 5.5.56; from 5.6.0 through 5.6.36
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 12
How to fix
Upgrade to a fixed version: MariaDB 10.0.32, 10.1.26, 10.2.8, 5.5.57. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3922
- http://www.debian.org/security/2017/dsa-3944
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://www.securityfocus.com/bid/99736
- http://www.securitytracker.com/id/1038928
- https://access.redhat.com/errata/RHSA-2017:2787
- https://access.redhat.com/errata/RHSA-2018:0279
- https://access.redhat.com/errata/RHSA-2018:0574
- https://access.redhat.com/errata/RHSA-2018:2439
- https://access.redhat.com/errata/RHSA-2018:2729
- https://www.debian.org/security/2017/dsa-3955
- http://www.debian.org/security/2017/dsa-3922
Get alerted when CVE-2017-3636 or the next vulnerability affects your stack