What’s Vulnerable › Vulnerabilities
CVE-2017-4920
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-05 · updated 2026-06-17
- Weakness: CWE-400
Description
The implementation of the OSPF protocol in VMware NSX-V Edge 6.2.x prior to 6.2.8 and NSX-V Edge 6.3.x prior to 6.3.3 doesn't correctly handle the link-state advertisement (LSA). A rogue LSA may exploit this issue resulting in continuous sending of LSAs between two routers eventually going in loop or loss of connectivity.
Affected products
- VMware NSX-V Edge: from 6.2.0 before 6.2.8; from 6.3.0 before 6.3.3 — fixed in 6.2.8, 6.3.3
- VMware NSX-V Edge: from 6.2.x prior through 6.2.8; from 6.3.x prior through 6.3.3
How to fix
Upgrade to a fixed version: VMware NSX-V Edge 6.2.8, 6.3.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/100277
- https://www.vmware.com/security/advisories/VMSA-2017-0014.html
- http://www.securityfocus.com/bid/100277
- https://www.vmware.com/security/advisories/VMSA-2017-0014.html
Get alerted when CVE-2017-4920 or the next vulnerability affects your stack