What’s Vulnerable › Vulnerabilities
CVE-2017-4933
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-20 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware ESXi (6.5 before ESXi650-201710401-BG), Workstation (12.x before 12.5.8), and Fusion (8.x before 8.5.9) contain a vulnerability that could allow an authenticated VNC session to cause a heap overflow via a specific set of VNC packets resulting in heap corruption. Successful exploitation of this issue could result in remote code execution in a virtual machine via the authenticated VNC session. Note: In order for exploitation to be possible in ESXi, VNC must be manually enabled in a virtual machine's .vmx configuration file. In addition, ESXi must be configured to allow VNC traffic through the built-in firewall.
Affected products
- VMware ESXi: 6.5, 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101 (+24)
- VMware Fusion: from 8.0.0 before 8.5.9 — fixed in 8.5.9
- VMware Workstation Pro: from 12.0.0 before 12.5.8; 14.0, 14.1.0 — fixed in 12.5.8
How to fix
Upgrade to a fixed version: VMware Fusion 8.5.9; VMware Workstation Pro 12.5.8. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040024
- http://www.securitytracker.com/id/1040025
- https://www.vmware.com/security/advisories/VMSA-2017-0021.html
- http://www.securitytracker.com/id/1040024
- http://www.securitytracker.com/id/1040025
- https://www.vmware.com/security/advisories/VMSA-2017-0021.html
Get alerted when CVE-2017-4933 or the next vulnerability affects your stack