What’s Vulnerable › Vulnerabilities
CVE-2017-4946
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-05 · updated 2026-06-17
- Weakness: CWE-863
Description
The VMware V4H and V4PA desktop agents (6.x before 6.5.1) contain a privilege escalation vulnerability. Successful exploitation of this issue could result in a low privileged windows user escalating their privileges to SYSTEM.
Affected products
- VMware Vrealize Operations For Horizon: from 6.0 before 6.5.1 — fixed in 6.5.1
- VMware Vrealize Operations For Published Applications: from 6.1.0 before 6.5.1 — fixed in 6.5.1
- VMware vRealize Operations for Horizon (V4H): 6.x before 6.5.1
- VMware vRealize Operations for Published Applications (V4PA): 6.x before 6.5.1
How to fix
Upgrade to a fixed version: VMware Vrealize Operations For Horizon 6.5.1; VMware Vrealize Operations For Published Applications 6.5.1. Check the vendor advisory for mitigations.
References
- http://gosecure.net/2018/01/10/vmware-horizon-v4h-v4pa-desktop-agent-privilege-escalation-vulnerability-cve-2017-4946/
- http://www.securityfocus.com/bid/102441
- http://www.securitytracker.com/id/1040136
- https://www.vmware.com/us/security/advisories/VMSA-2018-0003.html
- http://gosecure.net/2018/01/10/vmware-horizon-v4h-v4pa-desktop-agent-privilege-escalation-vulnerability-cve-2017-4946/
- http://www.securityfocus.com/bid/102441
- http://www.securitytracker.com/id/1040136
- https://www.vmware.com/us/security/advisories/VMSA-2018-0003.html
Get alerted when CVE-2017-4946 or the next vulnerability affects your stack