What’s Vulnerable › Vulnerabilities
CVE-2017-5130
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-07 · updated 2026-06-17
- Weakness: CWE-787
Description
An integer overflow in xmlmemory.c in libxml2 before 2.9.5, as used in Google Chrome prior to 62.0.3202.62 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted XML file.
Affected products
- Debian Linux: 8.0, 9.0
- Google Chrome: before 62.0.3202.62 — fixed in 62.0.3202.62
- xmlsoft libxml2: before 2.9.5 — fixed in 2.9.5
How to fix
Upgrade to a fixed version: Google Chrome 62.0.3202.62; xmlsoft libxml2 2.9.5. Check the vendor advisory for mitigations.
References
- http://bugzilla.gnome.org/show_bug.cgi?id=783026
- http://www.securityfocus.com/bid/101482
- https://access.redhat.com/errata/RHSA-2017:2997
- https://chromereleases.googleblog.com/2017/10/stable-channel-update-for-desktop.html
- https://crbug.com/722079
- https://git.gnome.org/browse/libxml2/commit/?id=897dffbae322b46b83f99a607d527058a72c51ed
- https://lists.debian.org/debian-lts-announce/2017/11/msg00034.html
- https://lists.debian.org/debian-lts-announce/2022/04/msg00004.html
- https://security.gentoo.org/glsa/201710-24
- https://security.netapp.com/advisory/ntap-20190719-0001/
- https://www.oracle.com/security-alerts/cpuapr2020.html
- http://bugzilla.gnome.org/show_bug.cgi?id=783026
Get alerted when CVE-2017-5130 or the next vulnerability affects your stack