What’s Vulnerable › Vulnerabilities
CVE-2017-5194
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Use-after-free vulnerability in Irssi before 0.8.21 allows remote attackers to cause a denial of service (crash) via an invalid nick message.
Affected products
- Debian Linux: 7.0
- Irssi: before 0.8.21 — fixed in 0.8.21
How to fix
Upgrade to a fixed version: Irssi 0.8.21. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/01/06/1
- http://www.securityfocus.com/bid/95310
- https://irssi.org/security/irssi_sa_2017_01.txt
- https://lists.debian.org/debian-lts-announce/2017/12/msg00022.html
- https://security.gentoo.org/glsa/201701-45
- http://www.openwall.com/lists/oss-security/2017/01/06/1
- http://www.securityfocus.com/bid/95310
- https://irssi.org/security/irssi_sa_2017_01.txt
- https://lists.debian.org/debian-lts-announce/2017/12/msg00022.html
- https://security.gentoo.org/glsa/201701-45
Get alerted when CVE-2017-5194 or the next vulnerability affects your stack