What’s Vulnerable › Vulnerabilities
CVE-2017-5205
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-01-28 · updated 2026-06-17
- Weakness: CWE-119
Description
The ISAKMP parser in tcpdump before 4.9.0 has a buffer overflow in print-isakmp.c:ikev2_e_print().
Affected products
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- The Tcpdump Group tcpdump: before 4.9.0 — fixed in 4.9.0
How to fix
Upgrade to a fixed version: The Tcpdump Group tcpdump 4.9.0. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3775
- http://www.securityfocus.com/bid/95852
- http://www.securitytracker.com/id/1037755
- https://access.redhat.com/errata/RHSA-2017:1871
- https://security.gentoo.org/glsa/201702-30
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1494526.html
- http://www.debian.org/security/2017/dsa-3775
- http://www.securityfocus.com/bid/95852
- http://www.securitytracker.com/id/1037755
- https://access.redhat.com/errata/RHSA-2017:1871
- https://security.gentoo.org/glsa/201702-30
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1494526.html
Get alerted when CVE-2017-5205 or the next vulnerability affects your stack