What’s Vulnerable › Vulnerabilities
CVE-2017-5208
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-08-22 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the wrestool program in icoutils before 0.31.1 allows remote attackers to cause a denial of service (memory corruption) via a crafted executable, which triggers a denial of service (application crash) or the possibility of execution of arbitrary code.
Affected products
- Debian Linux: 8.0
- Icoutils Project Icoutils: before 0.31.1 — fixed in 0.31.1
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.3, 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Icoutils Project Icoutils 0.31.1. Check the vendor advisory for mitigations.
References
- http://rhn.redhat.com/errata/RHSA-2017-0837.html
- http://www.debian.org/security/2017/dsa-3756
- http://www.openwall.com/lists/oss-security/2017/01/08/5
- http://www.securityfocus.com/bid/95315
- https://bugzilla.redhat.com/show_bug.cgi?id=1411251
- https://security.gentoo.org/glsa/201801-12
- http://rhn.redhat.com/errata/RHSA-2017-0837.html
- http://www.debian.org/security/2017/dsa-3756
- http://www.openwall.com/lists/oss-security/2017/01/08/5
- http://www.securityfocus.com/bid/95315
- https://bugzilla.redhat.com/show_bug.cgi?id=1411251
- https://security.gentoo.org/glsa/201801-12
Get alerted when CVE-2017-5208 or the next vulnerability affects your stack