What’s Vulnerable › Vulnerabilities
CVE-2017-5331
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-04 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow in the check_offset function in b/wrestool/fileread.c in icoutils before 0.31.1 allows local users to cause a denial of service (process crash) and execute arbitrary code via a crafted executable.
Affected products
- Canonical Ubuntu Linux: 12.04
- Debian Linux: 8.0, 9.0
- Icoutils Project Icoutils: before 0.31.1 — fixed in 0.31.1
- openSUSE Leap: 42.1, 42.2
- Opensuse: 13.2
How to fix
Upgrade to a fixed version: Icoutils Project Icoutils 0.31.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00026.html
- http://www.debian.org/security/2017/dsa-3765
- http://www.openwall.com/lists/oss-security/2017/01/11/3
- http://www.securityfocus.com/bid/95378
- http://www.ubuntu.com/usn/USN-3178-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1412248
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00024.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2017-01/msg00026.html
- http://www.debian.org/security/2017/dsa-3765
Get alerted when CVE-2017-5331 or the next vulnerability affects your stack