What’s Vulnerable › Vulnerabilities

CVE-2017-5340

Description

Zend/zend_hash.c in PHP before 7.0.15 and 7.1.x before 7.1.1 mishandles certain cases that require large array allocations, which allows remote attackers to execute arbitrary code or cause a denial of service (integer overflow, uninitialized memory access, and use of arbitrary destructor function pointers) via crafted serialized data.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.0.15, 7.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-5340 or the next vulnerability affects your stack