What’s Vulnerable › Vulnerabilities
CVE-2017-5356
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-03-03 · updated 2026-06-17
- Weakness: CWE-125
Description
Irssi before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a string containing a formatting sequence (%[) without a closing bracket (]).
Affected products
- Debian Linux: 7.0
- Irssi: before 0.8.21 — fixed in 0.8.21
How to fix
Upgrade to a fixed version: Irssi 0.8.21. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/01/12/8
- http://www.openwall.com/lists/oss-security/2017/01/13/2
- http://www.securityfocus.com/bid/96581
- https://blog.fuzzing-project.org/55-Fuzzing-Irssi-with-Perl-Scripts.html
- https://irssi.org/security/irssi_sa_2017_01.txt
- https://lists.debian.org/debian-lts-announce/2017/12/msg00022.html
- http://www.openwall.com/lists/oss-security/2017/01/12/8
- http://www.openwall.com/lists/oss-security/2017/01/13/2
- http://www.securityfocus.com/bid/96581
- https://blog.fuzzing-project.org/55-Fuzzing-Irssi-with-Perl-Scripts.html
- https://irssi.org/security/irssi_sa_2017_01.txt
- https://lists.debian.org/debian-lts-announce/2017/12/msg00022.html
Get alerted when CVE-2017-5356 or the next vulnerability affects your stack