What’s Vulnerable › Vulnerabilities
CVE-2017-5447
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-11 · updated 2026-06-17
- Weakness: CWE-416
Description
An out-of-bounds read during the processing of glyph widths during text layout. This results in a potentially exploitable crash and could allow an attacker to read otherwise inaccessible memory. This vulnerability affects Thunderbird < 52.1, Firefox ESR < 45.9, Firefox ESR < 52.1, and Firefox < 53.
Affected products
- Debian Linux: 9.0
- Mozilla Firefox: before 45.9.0; before 53.0; 52.0 — fixed in 45.9.0, 53.0
- Mozilla Thunderbird: before 52.1.0 — fixed in 52.1.0
- Red Hat Enterprise Linux: 6.0, 7.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 45.9.0, 53.0; Mozilla Thunderbird 52.1.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/97940
- http://www.securitytracker.com/id/1038320
- https://access.redhat.com/errata/RHSA-2017:1104
- https://access.redhat.com/errata/RHSA-2017:1106
- https://access.redhat.com/errata/RHSA-2017:1201
- https://bugzilla.mozilla.org/show_bug.cgi?id=1343552
- https://www.debian.org/security/2017/dsa-3831
- https://www.exploit-db.com/exploits/42071/
- https://www.mozilla.org/security/advisories/mfsa2017-10/
- https://www.mozilla.org/security/advisories/mfsa2017-11/
- https://www.mozilla.org/security/advisories/mfsa2017-12/
- https://www.mozilla.org/security/advisories/mfsa2017-13/
Get alerted when CVE-2017-5447 or the next vulnerability affects your stack