What’s Vulnerable › Vulnerabilities
CVE-2017-5455
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-11 · updated 2026-06-17
Description
The internal feed reader APIs that crossed the sandbox barrier allowed for a sandbox escape and escalation of privilege if combined with another vulnerability that resulted in remote code execution inside the sandboxed process. This vulnerability affects Firefox ESR < 52.1 and Firefox < 53.
Affected products
- Mozilla Firefox: before 53.0; before 52.1.0 — fixed in 52.1.0, 53.0
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 52.1.0, 53.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/97940
- http://www.securitytracker.com/id/1038320
- https://access.redhat.com/errata/RHSA-2017:1106
- https://bugzilla.mozilla.org/show_bug.cgi?id=1341191
- https://www.mozilla.org/security/advisories/mfsa2017-10/
- https://www.mozilla.org/security/advisories/mfsa2017-12/
- http://www.securityfocus.com/bid/97940
- http://www.securitytracker.com/id/1038320
- https://access.redhat.com/errata/RHSA-2017:1106
- https://bugzilla.mozilla.org/show_bug.cgi?id=1341191
- https://www.mozilla.org/security/advisories/mfsa2017-10/
- https://www.mozilla.org/security/advisories/mfsa2017-12/
Get alerted when CVE-2017-5455 or the next vulnerability affects your stack