What’s Vulnerable › Vulnerabilities
CVE-2017-5509
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-24 · updated 2026-06-17
- Weakness: CWE-787
Description
coders/psd.c in ImageMagick allows remote attackers to have unspecified impact via a crafted PSD file, which triggers an out-of-bounds write.
Affected products
- ImageMagick: before 6.9.7-4; from 7.0.0-0 before 7.0.4-4 — fixed in 6.9.7-4, 7.0.4-4
How to fix
Upgrade to a fixed version: ImageMagick 6.9.7-4, 7.0.4-4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95751
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851377
- https://github.com/ImageMagick/ImageMagick/commit/37a1710e2dab6ed91128ea648d654a22fbe2a6af
- https://github.com/ImageMagick/ImageMagick/commit/d4ec73f866a7c42a2e7f301fcd696e5cb7a7d3ab
- https://github.com/ImageMagick/ImageMagick/issues/350
- https://security.gentoo.org/glsa/201702-09
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95751
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851377
Get alerted when CVE-2017-5509 or the next vulnerability affects your stack