What’s Vulnerable › Vulnerabilities
CVE-2017-5510
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-03-24 · updated 2026-06-17
- Weakness: CWE-787
Description
coders/psd.c in ImageMagick allows remote attackers to have unspecified impact via a crafted PSD file, which triggers an out-of-bounds write.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- ImageMagick: before 6.9.7-4; from 7.0.0-0 before 7.0.4-4 — fixed in 6.9.7-4, 7.0.4-4
How to fix
Upgrade to a fixed version: ImageMagick 6.9.7-4, 7.0.4-4. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
- http://www.securityfocus.com/bid/95755
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851376
- https://github.com/ImageMagick/ImageMagick/commit/91cc3f36f2ccbd485a0456bab9aebe63b635da88
- https://github.com/ImageMagick/ImageMagick/commit/e87af64b1ff1635a32d9b6162f1b0e260fb54ed9
- https://github.com/ImageMagick/ImageMagick/issues/348
- https://security.gentoo.org/glsa/201702-09
- http://www.debian.org/security/2017/dsa-3799
- http://www.openwall.com/lists/oss-security/2017/01/16/6
- http://www.openwall.com/lists/oss-security/2017/01/17/5
Get alerted when CVE-2017-5510 or the next vulnerability affects your stack